Thread: BR03-92 Losing Time

Results 1 to 3 of 3
  1. #1
    Member HongNinja's Avatar
    Join Date
    Jul 2010
    Location
    AZ
    Posts
    128

    BR03-92 Losing Time

    Hello All,

    My BR03 has been keeping amazing time up until recently. I was averaging about +- 4 secs a day, but recently it's jumped to around 10secs a day. No obvious reasons, just noticed my timepiece was further behind then normal over the elapsed days.

    Anyone know why this might be happening or any quick fixes? Maybe it's just time for a service? Watch is only 3 years old.

    Would appreciate any help from my fellow B&R clan.

    Thanks!
    Brandon

  2. #2
    Member akira23's Avatar
    Join Date
    Dec 2009
    Location
    United States
    Posts
    977

    Re: BR03-92 Losing Time

    Hi,
    I would let your Br03 wind down completely and then set the time and check the time again. See if it does the +10 sec. a day... But it may need to be de-magnetized....
    Tempus Fugit.....

  3. #3
    Member
    Join Date
    Feb 2008
    Location
    NYS
    Posts
    615

    Re: BR03-92 Losing Time

    I understand that there is no magnetic shielding on the instrument series...
    TT Cartier Santos
    Tag Heuer F1 Chrono
    1977 Omega Deville
    Seiko Orange Monster

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •