Got my Waltham PW running.
Like Tree3Likes
  • 2 Post By bsshog40
  • 1 Post By Michael Maddan

Thread: Got my Waltham PW running.

Results 1 to 3 of 3
  1. #1
    Member bsshog40's Avatar
    Join Date
    Apr 2015
    Location
    Tx.
    Posts
    2,173

    Got my Waltham PW running.

    I bought this Waltham Model 1883 about 3 years ago. Never has run. It's an 18s, 15j with a Sterling Grade movement. I finally decided to take it apart and clean it. I always take pics of things I tear apart so I know how they go back together but I always forget to take pics of it going back together. Lol So here are the dirty pics. Lol It's been running pretty good the last 7 hrs. About 3 minutes slow. Time update. Has run 20 hrs now and is still 3 min slow.

    Attached Images Attached Images













    Last edited by bsshog40; November 27th, 2017 at 14:09.
    badbackdan and OPChagall like this.
    Bobby - My original music! Check me out! Thanks!
    https://www.youtube.com/playlist?lis...11CC8CC6093D80

  2. #2
    Member
    Join Date
    Aug 2010
    Location
    Maine, USA
    Posts
    1,310

    Re: Got my Waltham PW running.

    bsshog40...so far so good! These Model 1883's have usually seen lots of use, and were not always Serviced by folks trained at the Factory in Massachusetts...! I've worked on a few dozen, and they always have 'issues', but respond very well to TLC and a bit of balance work ( timing screws / hairspring / poise / pivots / etc...! ).

    They're fun to work on. Enjoy. Michael.
    bsshog40 likes this.

  3. #3
    Member bsshog40's Avatar
    Join Date
    Apr 2015
    Location
    Tx.
    Posts
    2,173

    Re: Got my Waltham PW running.

    I think I got lucky on this one. It's been running since I think about 11:20am Sunday. I've been keeping checks on it all day yesterday and this morn. It was running 3 mins behind after the first 3-4 hrs. But since then and as of 3:30pm today, it is still the 3 mins behind. I'm presuming that it just had to settle in the first hours. So 28hrs later, still 3 mins slow and it is still running. Curious to see when it stops. Lol
    Bobby - My original music! Check me out! Thanks!
    https://www.youtube.com/playlist?lis...11CC8CC6093D80

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Have a new problem with my Waltham PW
      By bsshog40 in forum Watchmaking
      Replies: 8
      Last Post: November 17th, 2017, 14:19
    2. Quick story about my Waltham PW
      By ml10 in forum Vintage & Pocket watches
      Replies: 5
      Last Post: May 20th, 2017, 17:45
    3. Waltham Permaforce, Waltham 65, Waltham 100, Waltham Cyclotron
      By ballucan1999 in forum Vintage & Pocket watches
      Replies: 8
      Last Post: March 9th, 2017, 03:15
    4. My second Waltham PW (many pics)
      By bubba48 in forum Vintage & Pocket watches
      Replies: 4
      Last Post: May 27th, 2016, 14:59
    5. Waltham PW to WW conversion
      By Marrick in forum Vintage & Pocket watches
      Replies: 3
      Last Post: May 28th, 2009, 21:54

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •