GW300 battery problems?

Thread: GW300 battery problems?

Results 1 to 6 of 6
  1. #1
    Member lockwood1's Avatar
    Join Date
    Feb 2006
    Location
    USA
    Posts
    1,571

    GW300 battery problems?

    Hello there guys:
    I bought a GW300 and received it last friday. The thing is that the watch battery indicator was at medium. OK so I took it to work
    and spent almost every day with it. It was a hot sunny day and at the end of the day the battery indicator still was at medium. This is not normal behavior I have other solar watches and gave them the same
    charging time and marks full on the display. This GW300 uses module 2608 and storage battery CTL1616. Sjors I read something about this a few
    months ago don't remember where but what to do? is this watch damage?
    how to fix this situation?


    Regards

  2. #2
    Member
    Join Date
    Feb 2006
    Location
    Chitown, IL
    Posts
    5,446

    Re: GW300 battery problems?

    I think there is a Sticky thread, or a how to thread on these... I thinkyou can use a different battery and that should take care of it.

    Neil

  3. #3
    Member lockwood1's Avatar
    Join Date
    Feb 2006
    Location
    USA
    Posts
    1,571

    Re: GW300 battery problems?

    Yeahp! GW300 definitely have an issue with the battery found the threads. Do I have to send the watch to Casio or can I do this job myself?

  4. Remove Advertisements
    WatchUSeek.com
    Advertisements
     

  5. #4
    Member Buzzbait's Avatar
    Join Date
    Mar 2006
    Location
    Upstate New York, USA
    Posts
    4,076

    Re: GW300 battery problems?

    This doesn't sound like the infamous CTL1616 battery issue to me. When the battery goes bad, you'll never get to medium.

    I'd let it sit in a windows for a couple days, where it gets some nice sunlight. It can take quite some time to bring a GW-300 from medium to high.

    An watch out for that AUTO-EL function. It can drain the battery very quickly.

  6. #5
    Member lockwood1's Avatar
    Join Date
    Feb 2006
    Location
    USA
    Posts
    1,571

    Re: GW300 battery problems?

    Quote Originally Posted by Buzzbait View Post
    This doesn't sound like the infamous CTL1616 battery issue to me. When the battery goes bad, you'll never get to medium.

    I'd let it sit in a windows for a couple days, where it gets some nice sunlight. It can take quite some time to bring a GW-300 from medium to high.

    An watch out for that AUTO-EL function. It can drain the battery very quickly.
    Hey buzzbait I'll do what you said and see what's up

  7. #6
    Member trozau's Avatar
    Join Date
    Aug 2007
    Location
    G-Shockland, USA
    Posts
    747

    Cool Re: GW300 battery problems?

    See tribe125's response on this thread ===> https://forums.watchuseek.com/showthread.php?t=79481

    It may be relevant to your problem.
    trozau (troy ounce gold)
    honi soit qui mal y pense
    http://forums.collectors.com/attachments//trozau_ani.gif
    gold - the barbarous relic!

    Does anybody really know what time it is?
    Robert Lamm of the group Chicago, 1969

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •