GWG-1000 Mudmaster button question.
Like Tree6Likes
  • 2 Post By Omega_JB
  • 2 Post By sticky
  • 2 Post By ricPe

Thread: GWG-1000 Mudmaster button question.

Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Nov 2007
    Posts
    168

    GWG-1000 Mudmaster button question.

    I have trawled the internet for this issue but cannot find anything.
    When i get my Mudmaster wet, after its dry and i press any of the buttons inc the light , i get a squelching noise. There is no water in the watch its totally sealed.
    The noise goes away when the buttons must be fully dried out.
    Is this normal? Does anyone else get this?
    Thanks

  2. #2
    Member
    Join Date
    Apr 2019
    Location
    Northern Virginia
    Posts
    26

    Re: GWG-1000 Mudmaster button question.

    I'm going to go out on a limb and say that's not normal.
    I'd contact Casio and see what they say.

    Sent from my SM-N960U using Tapatalk
    WES51 and memento_mori like this.

  3. #3
    Member sticky's Avatar
    Join Date
    Apr 2013
    Location
    South Yorkshire
    Posts
    54,282

    Re: GWG-1000 Mudmaster button question.

    I’ve experienced a similar phenomenon (not with my Muddy) and just thought that it was normal as it soon went away as the watch dried out more.
    WES51 and memento_mori like this.

  4. Remove Advertisements
    WatchUSeek.com
    Advertisements
     

  5. #4
    Member
    Join Date
    Nov 2007
    Posts
    168

    Re: GWG-1000 Mudmaster button question.

    Quote Originally Posted by sticky View Post
    I’ve experienced a similar phenomenon (not with my Muddy) and just thought that it was normal as it soon went away as the watch dried out more.
    Yep that's what i get.
    Buttons still work normally with the squelch and then dry out.
    I have emailed Casio so i will wait and see what the response is.

  6. #5
    Member ricPe's Avatar
    Join Date
    Jun 2018
    Location
    Croatia
    Posts
    190

    Re: GWG-1000 Mudmaster button question.

    It is normal.get the same noise on my gw9400.i guess a little water gets between metal butons and resin,but it cant get inside the case.dont worry.

    Poslano sa mog FRD-L09 koristeći Tapatalk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •