GWM5610 & G5600E buttons not working ( module 3159 & 3160 )

Thread: GWM5610 & G5600E buttons not working ( module 3159 & 3160 )

Results 1 to 7 of 7
  1. #1
    Member oz2124's Avatar
    Join Date
    Sep 2012
    Location
    GMT+10
    Posts
    313

    GWM5610 & G5600E buttons not working ( module 3159 & 3160 )

    Hi all..

    I need advice on my g-shock problem, I have g5600e and gwm5610bc, I would like to make my GWM5610 standard display so I swap it with G5600e display, then after I finish assemble the watches, all the buttons doesn't work and the watch display reset to 12:00, but the "CHG" signal keep blinking up to about 30 minutes before the battery indicator back to "H" but the all 4 buttons still not working.

    what happen to the watch and how to fix it ?

    please kindly advice on this

    thanks n regards.

  2. #2
    Member xevious's Avatar
    Join Date
    Feb 2008
    Location
    near Manhattan... Status: Changing course, hard about
    Posts
    6,100

    Re: GWM5610 & G5600E buttons not working ( module 3159 & 3160 )

    These watches have slightly different casing designs. To my knowledge, they're not compatible. I'm not sure how much of a difficult time you had getting the module swap to complete, but it is very likely from what you're describing is that the contacts on one or more buttons is wedged into constant contact. When that happens, no buttons will function. If I'm right about this, it may be due to the improper fitment of the module. Or... you may simply have to make a minor adjustment, if indeed the modules are interchangeable between these two casings.

    The easiest way to check is by removing the module again and seeing if you can activate the button contacts manually. You may find you'll have to swap the modules back into their respective original casings.
    In rotation: Citizen Attesa ATV53-2834, Eco Drives | Omega Seamaster | CASIO: TW-7000, MRG-220, RevMan, G-2000D, DW-5700ML, GW-9100 | Seiko SKA-413, SBPG001

  3. #3
    Member oz2124's Avatar
    Join Date
    Sep 2012
    Location
    GMT+10
    Posts
    313

    Re: GWM5610 & G5600E buttons not working ( module 3159 & 3160 )

    Quote Originally Posted by xevious View Post
    These watches have slightly different casing designs. To my knowledge, they're not compatible. I'm not sure how much of a difficult time you had getting the module swap to complete, but it is very likely from what you're describing is that the contacts on one or more buttons is wedged into constant contact. When that happens, no buttons will function. If I'm right about this, it may be due to the improper fitment of the module. Or... you may simply have to make a minor adjustment, if indeed the modules are interchangeable between these two casings.

    The easiest way to check is by removing the module again and seeing if you can activate the button contacts manually. You may find you'll have to swap the modules back into their respective original casings.





    They are exactly have the same case, and even the module different only gwm is with multiband.

  4. Remove Advertisements
    WatchUSeek.com
    Advertisements
     

  5. #4
    Member
    Join Date
    Jun 2011
    Location
    Raincouver, BC, Canada
    Posts
    3,679

    Re: GWM5610 & G5600E buttons not working ( module 3159 & 3160 )

    open the G's again

    take out the modules

    try to press those contacts at those four buttons to test

    put back the modules, make sure they sit properly (sometimes you have to rotate the module a little bit for perfect fit)

    make sure the two small springs touch the solar panel while doing so

    press the buttons to test again

    if not, take out the battery and put back in the perform reset as instruction

    enjoy and good luck
    _________________
    Selfishness is not living as one wishes to live, it is asking others to live as one wishes to live.Oscar Wilde

  6. #5
    Member oz2124's Avatar
    Join Date
    Sep 2012
    Location
    GMT+10
    Posts
    313

    Re: GWM5610 & G5600E buttons not working ( module 3159 & 3160 )

    Quote Originally Posted by G-fob View Post
    open the G's again

    take out the modules

    try to press those contacts at those four buttons to test

    put back the modules, make sure they sit properly (sometimes you have to rotate the module a little bit for perfect fit)

    make sure the two small springs touch the solar panel while doing so

    press the buttons to test again

    if not, take out the battery and put back in the perform reset as instruction

    enjoy and good luck

    Thanks for your reply
    I have already try it and even remove the battery and perform reset procedure to both watches but still same.
    after reset the "chg" indicator will blinking up to about 30min and before back to H..and all button still not working.

  7. #6
    Member
    Join Date
    Jun 2011
    Location
    Raincouver, BC, Canada
    Posts
    3,679

    Re: GWM5610 & G5600E buttons not working ( module 3159 & 3160 )

    can you take a few pictures and post them ? I have messed up quite a few G's of mine but never encountered such problem. if it happens to both of your Gshocks then the last thing I can think of is you put in the battery wrongly, positive to negative side and vice versa

    regards
    _________________
    Selfishness is not living as one wishes to live, it is asking others to live as one wishes to live.Oscar Wilde

  8. #7
    Member oz2124's Avatar
    Join Date
    Sep 2012
    Location
    GMT+10
    Posts
    313

    Re: GWM5610 & G5600E buttons not working ( module 3159 & 3160 )

    Quote Originally Posted by G-fob View Post
    can you take a few pictures and post them ? I have messed up quite a few G's of mine but never encountered such problem. if it happens to both of your Gshocks then the last thing I can think of is you put in the battery wrongly, positive to negative side and vice versa

    regards
    Here are some pics..







    it seems okay for me..

    please advise

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •