Need Help with GW-9000A

Thread: Need Help with GW-9000A

Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Apr 2010
    Posts
    1

    Need Help with GW-9000A

    Hello everyone. I have lurked on this site for about a week doing searches and now have some specific questions I hope someone can answer for me.

    First a description of my issue. I own a GW-9000A mudman atomic solar I believe is referred to sometimes as the 5 eye model. I purchased the watch after mud destroyed my Luminox EVO. This mudman has proven to be far tougher and much more enjoyable to own than the luminox was.

    The band on this watch is held on by a series of 4 screws, 2 on each side. On one side one of the screws has broken off. Part of the screw is still inside the bezel. Barring the worlds smallest chisel and much more patience than I'll ever have, it's stuck in there. That side of the band has become separated from the bezel leaving only one screw holding it on.

    I believe to fix this watch I'll need a new bezel and a new screw to replace the one that has broken.

    I've located at casiosalesandservice.com a bezel for a g-9000 which looks pretty much the same as the one for this watch. Will it fit?

    Also where can I buy a new screw for the band? And do disassembly instructions exist for this online? I seem to recall seeing a photo tutorial of taking it all apart to for boiling purposes at some point.

  2. #2
    Member tribe125's Avatar
    Join Date
    Mar 2006
    Location
    UK
    Posts
    29,513

    Re: Need Help with GW-9000A

    The bezel will fit, and Casio should be able to provide the screw. Disassembly is simply a matter of undoing those screws and lifting off the bezel.
    I used to list my watches here until I realised it ruined people's Google searches...

  3. #3
    Member
    Join Date
    Apr 2009
    Location
    OKLAHOMA
    Posts
    2,569

    Re: Need Help with GW-9000A

    Here is a LINK to the thread you mentioned. Note that removing the 4 screws on the back is NOT required and I highly suggest not doing this. I did and the module shifted and I had a heck of a time getting all the buttons to work again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •