New Riseman owner - problems with pressure readings.

Thread: New Riseman owner - problems with pressure readings.

Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Nov 2012
    Posts
    7

    New Riseman owner - problems with pressure readings.

    Hey guys - just got my riseman in the mail from amazon and really like the watch so far but it seems that I'm having reading the pressure. The pressure graph/dial doesn't seem to be logging anything and when I hit the mode button to enter into pressure/temp mode I get a flat reading of 10 00 hPa although the altimeter seems to make a relatively accurate reading (about 80m off from GPS). Is there something I have to do to get the pressure graph to start recording? All I see is a single pixel in the upper right corner flashing.

  2. #2
    Member Sedi's Avatar
    Join Date
    May 2007
    Location
    Bamberg, Germany
    Posts
    13,980

    Re: New Riseman owner - problems with pressure readings.

    Hi and welcome!
    Just wait a little and you'll see a graph forming out of those pixels. The watch was probably at a different height so it can't display a graph when the difference was too big between your location and the last recorded one - the graph "dropped" out of the display because of the elevation-difference being too big.

    cheers, Sedi
    Cheers
    Sedi

  3. #3
    Member
    Join Date
    Nov 2012
    Posts
    7

    Re: New Riseman owner - problems with pressure readings.

    Thanks - literally got this watch out of the box and now the pressure readings are starting to change!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •