anyone had a quick-set date stop working?

Thread: anyone had a quick-set date stop working?

Results 1 to 6 of 6
  1. #1
    Member
    Join Date
    Jan 2007
    Location
    Seattle
    Posts
    318

    anyone had a quick-set date stop working?

    I went to set the date last night and found that the first crown position of the 2824 did nothing. I could click out the crown but turning it did not engage the date wheel. Adjusting the time still makes the date change perfectly at midnight, so I've essentially lost the quick-set function.

    Has anyone had this happen to them? Any idea how badly I've messed up my watch? It's puzzling me because I haven't treated this watch ill in any way. I'm trying to rack my brain to see if I changed the date between 8 and 2 or something along those lines, but can't think of anything yet.

    Dave

  2. #2

    Join Date
    Feb 2006
    Posts
    12,223

    Re: anyone had a quick-set date stop working?

    2824-2. 1st position is wind, 2nd is date 3rd is time set. you sure you have it in the right position? sometimes it hard to feel the 2nd position as it very close to the 3rd.

  3. #3
    Member
    Join Date
    Jan 2007
    Location
    Seattle
    Posts
    318

    Re: anyone had a quick-set date stop working?

    I'm sure. I get it in a position that neither moves the hands nor winds. But it also doesn't turn the date wheel. Grumble.

    Dave

  4. Remove Advertisements
    WatchUSeek.com
    Advertisements
     

  5. #4

    Join Date
    Feb 2006
    Posts
    12,223

    Re: anyone had a quick-set date stop working?

    okay, it was just a thought. I have a watch here that has a weak crown spring and requires alittle work to hit the position right. it is working though since the date is changing on its own. kind of wierd.try this. when in the date set position, turn the crown slow cw, the ccw and see it the date moves. also it would help to know the name and model of watch you are referring to. some don't have a quick set feature.

  6. #5
    Member
    Join Date
    Jan 2007
    Location
    Seattle
    Posts
    318

    Re: anyone had a quick-set date stop working?

    Interesting. Thanks for the tip, but no joy. It's a Stowa Marine Auto and definitely has quick-set - I've used it plenty of times before. Just odd. I emailed Stowa and they recommended trying to set the date while the time was at 6 o'clock. Interesting - not sure why that would work, and it didn't.

    Fortunately Stowa has great customer service. Unfortunately I have to send my baby to Germany. I might drop by a local watch repair place to see what they have to say before paying FedEx a bunch of money.

    Thanks for the tips. Very odd.

    Dave

  7. #6
    Member Denizen's Avatar
    Join Date
    Jul 2006
    Location
    ny
    Posts
    3,251

    Re: anyone had a quick-set date stop working?

    the marine auto uses an eta 2824 movement so a local watchmaker should be able to diagnose the problem and get an repair estimate.

    it might be more cost effective to have the him do it rather than sending it back to Germany. a fellow in the Sinn forum lost his U2 sending it back home.


    Quote Originally Posted by daviswalker View Post
    Interesting. Thanks for the tip, but no joy. It's a Stowa Marine Auto and definitely has quick-set - I've used it plenty of times before. Just odd. I emailed Stowa and they recommended trying to set the date while the time was at 6 o'clock. Interesting - not sure why that would work, and it didn't.

    Fortunately Stowa has great customer service. Unfortunately I have to send my baby to Germany. I might drop by a local watch repair place to see what they have to say before paying FedEx a bunch of money.

    Thanks for the tips. Very odd.

    Dave

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •