Issue with 1966 Omega Constellation Reference 168.004

Thread: Issue with 1966 Omega Constellation Reference 168.004

Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Apr 2011
    Posts
    3

    Issue with 1966 Omega Constellation Reference 168.004

    Purchased this from a friend. Runs fine. Date was way off and no date adjust or hacking so I just starting turning from 22nd...when I hit 8 it stopped allowing the time to move forward.


    After some fiddling and letting it stop, I find I can only adjust backwards and finally the crown totally unscrews and falls of (I managed to find it in the carpet thank satan).


    Am I doing something wrong? Lack of quick date is the suck.




    Tried to post photos but my post count is too low.


    I paid about $850 BTW is that a good deal?

  2. #2
    Member
    Join Date
    Apr 2011
    Posts
    3

    Re: Issue with 1966 Omega Constellation Reference 168.004

    Name:  Omega2.jpg
Views: 23
Size:  132.0 KBName:  Omega1.jpg
Views: 23
Size:  257.3 KB

    Photos

  3. #3
    Member
    Join Date
    Nov 2018
    Location
    Essex Uk
    Posts
    78

    Re: Issue with 1966 Omega Constellation Reference 168.004

    Must be a very common problem !, as my constellation with a 564 ( Quick change date) has exactly the same problem, apart from no date issue with mine.

    Unfortunately I can not tell you what the issue is ,as mine is still in at the watchmakers to fix this problem, rotor scraping and a service .

    It needs to go off to a watchmaker Im afraid !

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •