Railmaster is kaput - service needed

Thread: Railmaster is kaput - service needed

Results 1 to 2 of 2
  1. #1
    Member mjrchabot's Avatar
    Join Date
    Apr 2011
    Location
    London, Ontario
    Posts
    1,976

    Railmaster is kaput - service needed

    Hello all,
    Well, yesterday was a sad day. My new-to-me Railmaster that I acquired just a couple weeks ago is no longer working. The watch was originally purchased in April 2010.
    I wore it consistently for two weeks to the office each day and then put it on the winder after work (replaced it with my PO). It ran a steady -1.00sec/day for the two weeks so I was really surprised to find it dead in the water.
    The second hand will run about 4-5 secs and then stop. The balance spring just isn't moving... when I held it in a certain position it was running, but then I moved the watch and it immediately stopped.

    Any ideas what could be the problem? My last PO had a similar issue... just crapped out on me.

    Thanks,
    Mike
    In Rotation:
    Rolex 116000 - Blue "3,6,9" Arabic
    Tudor Black Bay 36
    Longines Heritage Conquest L1.411.4
    Seiko Presage SRPD36-J1 "Old Fashioned"
    Dan Henry 1964 Chrono - Panda
    Grandad's 1960s Wesport by Westclox (in for service)

  2. #2
    Member Quartersawn's Avatar
    Join Date
    Nov 2008
    Location
    Texas
    Posts
    5,202

    Re: Railmaster is kaput - service needed

    Sounds like something may be jamming it?

    I can't tell you what is wrong but I can recommend a watchmaker in Canada who does A+ work for a reasonable price.

    ArcherWatches.ca

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •