Seiko 7T62 / 7T32-6K19

Thread: Seiko 7T62 / 7T32-6K19

Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Jan 2015
    Location
    Washington, DC
    Posts
    12

    Seiko 7T62 / 7T32-6K19

    I have a yellow dialed Seiko 7T62 alarm chronograph watch. The watch is working, but the second sweep hand is stuck at about 55 seconds. I've been reading about this watch today and it is a bit unusual, since the front is marked with 7T62 and the back is marked with 7T32-6K19. It has one crown and two pushers so I'm calling it 7T62.

    Is there a trick to getting the sweep second hand to reset? I found some instructions online. I pulled the crown to 2nd position, pushed the top button for 2 seconds, then pressed the bottom, but nothing happened. I also tried setting the alarm, but it didn't activate. I had forgotten that it had an alarm and I don't think I ever used it. Thanks, Eric
    Attached Images Attached Images




  2. #2
    Member MrDisco99's Avatar
    Join Date
    Jul 2018
    Posts
    1,515

    Re: Seiko 7T62 / 7T32-6K19

    The way it should work is you pull the crown all the way out, then hold the top button until the sweep hand makes a full revolution. Then adjust it with the bottom button.

    Holding the top button down until a hand or group of hands make a full rotation is how you go from adjusting the running time on the "alarm" dial to adjusting the chrono seconds to adjusting the chrono minutes and back again. The hands are adjusted with the bottom button.

    The middle crown position allows you to quickset the date with the crown and set the alarm time with the bottom button.
    Casio DW5600E; Orient Bambino V3; Red Star 1963; Seiko SARB033, SKX007 (NH36), SNA411, SNK809 (rebuild), SSB033, SUP880; Timex Fairfield Small Seconds; Tissot Automatic III; Vostok 420059

  3. #3
    Member
    Join Date
    Jan 2015
    Location
    Washington, DC
    Posts
    12
    Thanks! I can get the alarm dial to move, but the sweep second hand isn't moving. I've tried pushing different combinations of buttons, but it doesn't budge. Nothing happens when I push button A.

    I've not managed to make the alarm work either, but I'll keep trying. I wonder if it's worth trying to get it working?
    Attached Images Attached Images


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •