Alpha Bracelet Won't Adjust

Thread: Alpha Bracelet Won't Adjust

Results 1 to 2 of 2
  1. #1
    Member visualplane's Avatar
    Join Date
    Jul 2014
    Location
    NYC
    Posts
    2,591

    Alpha Bracelet Won't Adjust

    I posted here 3 weeks ago without a reply, so maybe someone here knows.

    https://forums.watchuseek.com/f72/how...l#post29893586

    "I got an alpha daytona today, and when I unscrew the screw on the links, the band isn't popping out. There's 3 screws on one side, and 2 screws on the other side. I tried unscrewing all of them, and only one of the links would pop out. Any ideas?"

  2. #2
    Member Nokie's Avatar
    Join Date
    Jul 2011
    Location
    Marin County, CA
    Posts
    28,030

    Re: Alpha Bracelet Won't Adjust

    Pictures of the actual bracelet will help with responses.
    "Either he's dead or my watch has stopped"
    Groucho Marx

    "The only reason for time is so that everything does not happen at once..."
    Albert Einstein

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Similar Threads

    1. Alpha Daytona chrono won't reset
      By bodaciousllama in forum Chinese Mechanical watches
      Replies: 3
      Last Post: September 10th, 2011, 09:43
    2. SA Date Won't Adjust!!!
      By stuckinmudjeeper in forum Breitling
      Replies: 6
      Last Post: February 28th, 2010, 03:55
    3. Interesting...my watch winder won't power an Alpha explorer
      By joppinger in forum Chinese Mechanical watches
      Replies: 13
      Last Post: January 10th, 2010, 14:42
    4. Tried to clean Alpha crystal. Crown won't go back in :(
      By SquishyPanda in forum Chinese Mechanical watches
      Replies: 3
      Last Post: July 29th, 2008, 02:57
    5. Replies: 0
      Last Post: August 12th, 2007, 17:22

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •