EZM13 suddenly running slow.
Like Tree1Likes
  • 1 Post By Camguy

Thread: EZM13 suddenly running slow.

Results 1 to 9 of 9
  1. #1
    Member Camguy's Avatar
    Join Date
    Nov 2012
    Location
    Arlington VA
    Posts
    5,687

    EZM13 suddenly running slow.

    As in, quite suddenly a ~ minute per day slow. It's only about 2 1/2 years old. Surely it can't be time for a service already?

    Name:  22edb736811d6c41db70cef4f8dd4dc7.jpg
Views: 118
Size:  69.5 KB
    Spring-Diver likes this.

  2. #2
    Moderator Spring-Diver's Avatar
    Join Date
    Jan 2009
    Location
    Southern California (OC)
    Posts
    6,504

    Re: EZM13 suddenly running slow.

    Quote Originally Posted by Camguy View Post
    As in, quite suddenly a ~ minute per day slow. It's only about 2 1/2 years old. Surely it can't be time for a service already?

    Name:  22edb736811d6c41db70cef4f8dd4dc7.jpg
Views: 118
Size:  69.5 KB
    Man thats a bummer

    Im assuming its out of warranty, so maybe a call to RGM to get an estimate for repairs.

    Please keep us updated on this.


    Shannon


    Sent from my iPhone using Tapatalk
    My Seiko's: SBDB001 SD600M, SBDX001 Marine Master, SRP777, SRPA21 PADI,

    Casio: ProTrek 2500-A1

    My Sinns: EZM9, EZM14T1, EZM14-T1B, U1 Professional, 836

    Want

    Aquadive: Bathyscaphe Poseidon GMT 100, Bathyscaphe 100 Blue

    Sinn: U2C, UX S, 857 S, 900 S

    Seiko: SNR031J1, SNR035J1

  3. #3
    Member
    Join Date
    Oct 2016
    Posts
    1,022

    Re: EZM13 suddenly running slow.

    Quote Originally Posted by Camguy View Post
    As in, quite suddenly a ~ minute per day slow. It's only about 2 1/2 years old. Surely it can't be time for a service already?

    Name:  22edb736811d6c41db70cef4f8dd4dc7.jpg
Views: 118
Size:  69.5 KB
    Hate to hear that. Same one with the new blue in the capsule a while back right?

    Id send it in right away now, two indications of something.

    Very best of luck.


    Sent from my iPhone using Tapatalk

  4. Remove Advertisements
    WatchUSeek.com
    Advertisements
     

  5. #4
    Member Camguy's Avatar
    Join Date
    Nov 2012
    Location
    Arlington VA
    Posts
    5,687

    Re: EZM13 suddenly running slow.

    Well, I put it on my iPhone Timegraher app and all seems well (the amplitude seems a little low, but the app isn't that accurate). I'll see how it goes.

    Name:  IMG_0191.jpeg
Views: 97
Size:  95.0 KB

  6. #5
    Member bazza.'s Avatar
    Join Date
    Jan 2010
    Location
    UK at the min
    Posts
    865

    Re: EZM13 suddenly running slow.

    The EZM13 has a 3 year warranty but looking at the TimeGrapher result it's ok but as you say the amplitude is maybe a little low
    I just checked my one and to be fair it was one of the first ones they made number 26 my wife pre ordered it before they were released
    So it 4.5 years old



    I did a video on using this App to help regulate your own watch the other day if your interested
    https://youtu.be/zDt-ES3KNro
    Rolex Kermit, DRSD, SD4k ,Milgauss GV ,Red Sub ,OP 39 Red ,Batman ,Panerai 177 ,Seiko Tuna 007 ,Baby Monster, SQ100 ,Breitling Colt 41 ,Casio G-Shock 5610
    Zenith 1931 Pocket Watch , Laco ​Aachen Taupe , Memmingen , Corum Jumping Hours LE 001/300 , Sinn EZM1LE , EZM2-GSG9 , U2s , EZM13 , UX-GSG9 ,556-55Le

  7. #6
    Member
    Join Date
    Dec 2015
    Posts
    480

    Re: EZM13 suddenly running slow.

    Quote Originally Posted by Camguy View Post
    Well, I put it on my iPhone Timegraher app and all seems well (the amplitude seems a little low, but the app isn't that accurate). I'll see how it goes.
    So it was running very slow but now it's OK? That's strange....
    Any chance you accidentally set it a minute slow the first time? I've certainly done that a few times. I assume you didn't though in which case I'd keep an eye on it... hope it works out and all is good now but slow watches usually mean time for service in my experience.

  8. #7
    Member
    Join Date
    Jun 2018
    Location
    Germany
    Posts
    108

    Re: EZM13 suddenly running slow.

    ...if your app is not faulty, the Amplitude is much too low for a 2,5 year old watch.

    Quick check at SINNs website: "The average amplitude values of most watch movements made today are between 250 and 300. As the lubricant ages, this value gradually falls."
    The SZ02 SINN Caliber is based on the Valjoux 7750. So Amplitude should be around 270+. Most new ones (or with fresh OH) range between 280-310.

    My 4 years old EZM-13 still shows 290.....I would check double with a friends timegraber (or at the local jeweller) first and then send it in.
    Make sure it is fully winded-up first!

  9. #8
    Member vintage navitimer's Avatar
    Join Date
    Oct 2009
    Location
    Pittsburgh
    Posts
    950

    Re: EZM13 suddenly running slow.

    . . . . so, any update on your ezm13?
    Sorry I'm late . . . I couldn't figure out which watch to wear. Current collection, circa 1964 Breitling 806 Navitimer, Grand Seiko sbgr051, sbgt035, Rolex 116000 OP in blue with explorer hands, 114200 white Air King, 116000 OP Black Concentric and an 116600 Sea Dweller, Seiko sbcm025, 6309-7049, 7549-7010, 7c43-6010, 6458-6000, 6458-600b, 6306-7001, 7548-700f, and a NOS SBDX001, the only one exposed to hazardous conditions is my Citizen ny0040.

  10. #9
    Member Camguy's Avatar
    Join Date
    Nov 2012
    Location
    Arlington VA
    Posts
    5,687

    Re: EZM13 suddenly running slow.

    I wasn't as concerned with measuring the amplitude, and I only gave it time to gather a 55% "quality" read so I wouldn't put too much stock in what's probably a fairly inaccurate number.

    It has, however been keeping outstanding accuracy again, so it's a mystery.


    Quote Originally Posted by UOhrli View Post
    ...if your app is not faulty, the Amplitude is much too low for a 2,5 year old watch.

    Quick check at SINNs website: "The average amplitude values of most watch movements made today are between 250 and 300. As the lubricant ages, this value gradually falls."
    The SZ02 SINN Caliber is based on the Valjoux 7750. So Amplitude should be around 270+. Most new ones (or with fresh OH) range between 280-310.

    My 4 years old EZM-13 still shows 290.....I would check double with a friends timegraber (or at the local jeweller) first and then send it in.
    Make sure it is fully winded-up first!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts