Cannot demagnetize 7s26

Thread: Cannot demagnetize 7s26

Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Jun 2019
    Posts
    33

    Cannot demagnetize 7s26

    I am using the Lepsi app to detect magnetism in my watches. I have a 7s26 that shows up on the detector. I've tried one of the little blue watch demagnetizers, which I'm almost positive is working because I can feel the watch vibrate and stuff. I let it sit on the demagnetizer for about 10 seconds, and slowyl draw it up and away, above my head just to be safe. It still shows up on the detector! Is this normal?

  2. #2
    JAA
    JAA is offline
    Member JAA's Avatar
    Join Date
    Dec 2011
    Posts
    797

    Re: Cannot demagnetize 7s26

    I wouldn't trust my iPhone to detect watch magnetism. The app supposedly uses the phone's internal compass on the circuit board to see if the watch would move the compass. Use a regular compass app on the phone to see if the watch actually moves where the app points to "north."

    Also, if you can get your hands on a real mechanical compass (the kind with glass and pointer), check to see if your watch really moves the pointer. But if the watch runs ok and keeps time, I would stop worrying about it.

  3. #3
    Member SleeperAwake's Avatar
    Join Date
    Oct 2012
    Posts
    51
    I've seen several comments about how those cheap blue demagnetizers with the red button don't penetrate the watch case. So I have a Seiko diver 6r15 that a compass shows is magnetized and I've tried everything, including taking the case back off and gently setting the movement on my blue demagnetizer and it's still magnetized. So they're crap for sure. They might work on a screwdriver but I haven't tried yet. Next step is buying the gray ones that have the hole you pass the watch through it. Hope this helped

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •