Santos runs fast on the winder.

Thread: Santos runs fast on the winder.

Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    May 2019
    Location
    US
    Posts
    22

    Santos runs fast on the winder.

    Hello, I have a Wolf watch winder that I use to keep my watches active. I use the bidirectional setting.

    I noticed a strange behavior on my 2019 Santos Large in blue. When the watch has been on the winder for a while (say full day + overnight), it seems to run a few minutes faster. When I limit myself to maybe a one full run of winding cycle in a given day, the watch keeps time fine.

    Is this due to being overwound? Or magnetism built up?

    Events leading up to this discovery: I was on a trip for two weeks so I let the watch die out. Upon coming back I wound it (30-40 turns), wore it for a day, and put it back on the winder for rotation over night. And I saw that the watch was 2-3min faster.

    The watch runs fine if I limit the winder usage, but Iím not sure if itís a watch issue and needs to be taken in.

    Thanks.


    Sent from my iPhone using Tapatalk

  2. #2
    Member
    Join Date
    Apr 2017
    Posts
    60

    Re: Santos runs fast on the winder.

    Thatís how mine is too. I also have a Wolf Watch Winder and the New Large Santos. Iím thinking itís the position of the watch. Try all positions like watch face up or down and see how it goes.


    Sent from my iPhone using Tapatalk

  3. #3
    Member
    Join Date
    Mar 2008
    Posts
    649

    Re: Santos runs fast on the winder.

    I had a large (blue) model and did not have this problem- it was exceptionally accurate both on and off the winder.

    I then swapped it for a medium and this problem occurred. About 2-4 minutes fast on the winder and 30 seconds fast on wrist. Currently the watch is with Cartier and I'll post back with an update.

  4. Remove Advertisements
    WatchUSeek.com
    Advertisements
     

  5. #4
    Member
    Join Date
    Mar 2008
    Posts
    649

    Re: Santos runs fast on the winder.

    Update:

    Received my Santos back last week. Apparently they did a "full service"- see attached letter that came with it. Watch runs perfectly now both on wrist and winder. Running -1.0 sec/day.

    This doesn't really help diagnose the problem unfortunately, but I'm happy it's fixed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts